<!DOCTYPE html><html lang="en-US" class="no-js no-svg"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//cookie-cdn.cookiepro.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//use.fontawesome.com' /><link rel='dns-prefetch' href='//cdn.sierrasun.com' /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='wp-block-library-css' href='https://cdn.sierrasun.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-polls-css' href='https://cdn.sierrasun.com/wp-content/cache/busting/4/wp-content/plugins/wp-polls/polls-css-2.75.4.css' type='text/css' media='all' /><style id='wp-polls-inline-css' type='text/css'>.wp-polls .pollbar{margin:1px;font-size:6px;line-height:8px;height:8px;background-image:url(https://cdn.sierrasun.com/wp-content/plugins/wp-polls/images/default/pollbg.gif);border:1px solid #c8c8c8}</style><link rel='stylesheet' id='swift-main-css-css' href='https://cdn.sierrasun.com/wp-content/cache/busting/4/wp-content/themes/swift-news-theme/assets/css/main.min-1580996033.css' type='text/css' media='all' /><style id='swift-main-css-inline-css' type='text/css'>#layout-single article img{pointer-events:none;-webkit-user-select:none;-khtml-user-select:none;-moz-user-select:none;-o-user-select:none;user-select:none;-webkit-user-drag:none;-khtml-user-drag:none;-moz-user-drag:none;-o-user-drag:none;user-drag:none}</style><link rel='stylesheet' id='google-fonts-css-css' href='https://fonts.googleapis.com/css?family=Heebo%3A400%2C700%7CLora%3A400%2C400i%2C700&#038;display=swap&#038;ver=1.0' type='text/css' media='all' /><link rel='stylesheet' id='fontawesome-css-css' href='https://use.fontawesome.com/releases/v5.4.1/css/all.css?ver=5.0.13' type='text/css' media='all' /><link rel='stylesheet' id='weather-icons-css-css' media='print' onload="this.media='all'" href='https://cdn.sierrasun.com/wp-content/cache/busting/4/wp-content/themes/swift-news-theme/assets/css/vendors/weather-icons/weather-icons.min-2.0.css' type='text/css' /><link rel='stylesheet' id='lightslider-css-css' href='https://cdn.sierrasun.com/wp-content/cache/busting/4/wp-content/themes/swift-news-theme/assets/css/vendors/lightslider-1.1.6.css' type='text/css' media='all' /><link rel='stylesheet' id='lightgallery-css-css' href='https://cdn.sierrasun.com/wp-content/cache/busting/4/wp-content/themes/swift-news-theme/assets/css/vendors/lightgallery-1.6.11.css' type='text/css' media='all' /><link rel='stylesheet' id='fancybox-css-css' href='https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.5.6/jquery.fancybox.min.css?ver=3.5.6' type='text/css' media='all' /> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/jquery/3.3.1/jquery.min.js?ver=3.3.1'></script> <script type='text/javascript'>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</script> <link rel='https://api.w.org/' href='https://www.sierrasun.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sierrasun.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdn.sierrasun.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Honoring a valued community member, Stephen Bannar, with a spectacular view' href='https://www.sierrasun.com/news/honoring-a-valued-community-member-stephen-bannar-with-a-spectacular-view/' /><link rel='next' title='Prep roundup: Lady Wolverines win sixth straight' href='https://www.sierrasun.com/sports/prep-sports/prep-roundup-lady-wolverines-win-sixth-straight/' /><link rel="canonical" href="https://www.sierrasun.com/news/nevada-county-board-of-supervisor-candidates-make-their-case-to-voters/" /><link rel='shortlink' href='https://www.sierrasun.com/?p=135367' /><link rel="alternate" type="application/json+oembed" href="https://www.sierrasun.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sierrasun.com%2Fnews%2Fnevada-county-board-of-supervisor-candidates-make-their-case-to-voters%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.sierrasun.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sierrasun.com%2Fnews%2Fnevada-county-board-of-supervisor-candidates-make-their-case-to-voters%2F&#038;format=xml" /> <script>window.SGPMPopupLoader=window.SGPMPopupLoader||{ids:[],popups:{},call:function(w,d,s,l,id){
									w['sgp']=w['sgp']||function(){(w['sgp'].q=w['sgp'].q||[]).push(arguments[0]);};
									var sg1=d.createElement(s),sg0=d.getElementsByTagName(s)[0];
									if(SGPMPopupLoader && SGPMPopupLoader.ids && SGPMPopupLoader.ids.length > 0){SGPMPopupLoader.ids.push(id); return;}
									SGPMPopupLoader.ids.push(id);
									sg1.onload = function(){SGPMPopup.openSGPMPopup();}; sg1.async=true; sg1.src=l;
									sg0.parentNode.insertBefore(sg1,sg0);
									return {};
								}};</script><script>SGPMPopupLoader.call(window,document,'script','https://popupmaker.com/assets/lib/SGPMPopup.min.js','20a611ef');</script> <script async src="https://www.googletagmanager.com/gtag/js?id=AW-851550877"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'AW-851550877');</script>  <script>gtag('event', 'conversion', {'send_to': 'AW-851550877/FXboCPrZnacBEJ3FhpYD'});</script>  <script src="https://js.adsrvr.org/up_loader.1.1.0.js" type="text/javascript"></script> <script type="text/javascript">ttd_dom_ready( function() {
                if (typeof TTDUniversalPixelApi === 'function') {
                    var universalPixelApi = new TTDUniversalPixelApi();
                    universalPixelApi.init("eac6kka", ["0vwwwr2"], "https://insight.adsrvr.org/track/up");
                }
            });</script>  <script type='text/javascript'>// Access previously set cookie.
		function accessCookie( name ) {
		  var v = document.cookie.match('(^|;) ?' + name + '=([^;]*)(;|$)');
		  return v ? v[2] : null;
		}</script><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
          (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
          m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
        ga('create', 'UA-4028663-5', 'auto');
        ga('create', 'UA-4028663-63', 'auto', {'name': 'newTracker'});
 	      ga('require', 'displayfeatures');
	      ga('require', 'linkid');</script> <script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
			n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
			n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
			t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
			document,'script','https://connect.facebook.net/en_US/fbevents.js');
			// Insert Your Facebook Pixel ID below.
			fbq('init', '356889104458573');
			
			fbq('track', 'PageView');</script><noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=356889104458573&amp;ev=PageView&amp;noscript=1" /></noscript><meta name="google-site-verification" content="CAmPZTPpDcmzoJVTgpPPWPPYpPZmCY7GcByNz-NDCCA" /><meta name="__sync_contentCategory" content="Paid" /><meta name="__sync_tenantId" content="swc_gt"><link rel="shortcut icon" href="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/03/favicon.ico"><link rel="apple-touch-icon" sizes="180x180" href="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/03/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/03/favicon-32x32.png"><title>Nevada County Board of Supervisor candidates make their case to voters | SierraSun.com</title><meta name="description" content="Three candidates are looking to fill the Nevada County Board of Supervisors District 1 seat in the March 3 primary election. Incumbent Heidi Hall will face challengers Michael Taylor," /><meta name="keywords" content="COUNTY, FIRE, HOUSING, BUILDING, HALL, NEVADA, WILDER, COMMUNITY, TAYLOR, CANNABIS" /><meta property="og:title" content="Nevada County Board of Supervisor candidates make their case to voters"/><meta property="og:description" content="Three candidates are looking to fill the Nevada County Board of Supervisors District 1 seat in the March 3 primary election. Incumbent Heidi Hall will face challengers Michael Taylor,"/><meta property="og:url" content="https://www.sierrasun.com/news/nevada-county-board-of-supervisor-candidates-make-their-case-to-voters/"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@SierraSun_News"/><meta property="og:image" content="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-1024x343.jpg"/><meta property="og:image:type" content="image/jpeg"/><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="343" /><meta name="twitter:image" content="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-1024x343.jpg" /><meta property="og:image" content="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-1.jpg"/><meta property="og:image:type" content="image/jpeg"/><meta property="og:image:width" content="889" /><meta property="og:image:height" content="889" /><meta property="og:image" content="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-2-768x1024.jpg"/><meta property="og:image:type" content="image/jpeg"/><meta property="og:image:width" content="768" /><meta property="og:image:height" content="1024" /><meta property="og:image" content="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-3-683x1024.jpg"/><meta property="og:image:type" content="image/jpeg"/><meta property="og:image:width" content="683" /><meta property="og:image:height" content="1024" /><meta property="og:image" content="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-4-1024x667.jpg"/><meta property="og:image:type" content="image/jpeg"/><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="667" /><meta name="sniply-options" content="block" /><meta property="article:publisher" content="https://www.facebook.com/SierraSun1" /><meta name="author" content="John Orona" /><meta property="og:type" content="article" /> <script type="application/ld+json">{
				  "@context": "https://schema.org",
				  "@type": "NewsArticle",
				  "mainEntityOfPage": {
				    "@type": "WebPage",
				    "@id": "https://google.com/article"
				  },
					
				  "headline": "Nevada County Board of Supervisor candidates make their case to voters",
				  "image": [
				    "https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-1024x343.jpg","https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-1.jpg","https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-2-768x1024.jpg","https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-3-683x1024.jpg","https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-4-1024x667.jpg"
				   ],
				  "datePublished": "2020-02-05 19:17:00",
				  "dateModified": "2020-02-06 13:26:03",
					"author": {
						"@type": "Person",
						"name": "John Orona"
					},
				   "publisher": {
				    "@type": "Organization",
				    "name": "SierraSun.com",
				    "logo": {
				      "@type": "ImageObject",
				      "url": "https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/08/ss-logo-2x-1.png"
				    }
				  },
				  "description": "Three candidates are looking to fill the Nevada County Board of Supervisors District 1 seat in the March 3 primary election. Incumbent Heidi Hall will face challengers Michael Taylor, building contractor; and Deborah Wilder, small business owner.Incumbent District 2 Supervisor Ed Scofield is running unopposed for his seat while Hardy Bullock is running unopposed for&hellip;"
				}</script><meta property="fb:app_id" content="969997716343864" /><meta name="pubdate" content="20200205"><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head><body class="post-template-default single single-post postid-135367 single-format-standard sierrasun category-news category-politics"><div id="fb-root"></div> <script>(function(d, s, id) {
			  var js, fjs = d.getElementsByTagName(s)[0];
			  if (d.getElementById(id)) return;
			  js = d.createElement(s); js.id = id;
			  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.2&appId=969997716343864&autoLogAppEvents=1';
			  fjs.parentNode.insertBefore(js, fjs);
			}(document, 'script', 'facebook-jssdk'));</script> <script>function get_cookie_value(a) {
					var b = document.cookie.match('(^|;)\\s*' + a + '\\s*=\\s*([^;]+)');
					return b ? b.pop() : '';
				}
				var free_site = true;
var show_survey = true;
				var syncwall_cookie = get_cookie_value('syncwall-active-subscriber');

				if ( syncwall_cookie !== null ) {
					//console.log('SwiftDebug | js free_site: ' + free_site );
					//console.log('SwiftDebug | js show_survey: ' + show_survey );
					//console.log('SwiftDebug | js syncwall-active-subscriber cookie value: ' + syncwall_cookie );
				}</script> <script>if ( (free_site === true && show_survey === true) || (free_site === false && ( show_survey === true && (syncwall_cookie !== null && syncwall_cookie !== "true") ) ) ) {

	        console.log("SwiftDebug | Google Survey enabled");

					(function() {
	          var ARTICLE_URL = window.location.href;
	          var CONTENT_ID = 'everything';
	          document.write(
	            '<scr'+'ipt '+
	            'src="//survey.g.doubleclick.net/survey?site=_unkcvthkk64gai4trk4w5cb65y'+
	            '&amp;url='+encodeURIComponent(ARTICLE_URL)+
	            (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
	            '&amp;random='+(new Date).getTime()+
	            '" type="text/javascript">'+'\x3C/scr'+'ipt>');
	        })();

	      }
	      else {
	        console.log("SwiftDebug | Google Survey disabled");
	      }</script> <div class="row no-gutters banner-breaking"><div class="col"> <a href="https://www.sierrasun.com/news/superintendent-chief-learning-officer-leri-retiring-from-tahoe-truckee-unified-school-district/"><h4><strong>Breaking News</strong> - Superintendent Chief Learning Officer Rob Leri retiring from Tahoe Truckee Unified School District</h4></a></div></div><header><nav id="nav-publication" class="navbar navbar-expand d-none d-lg-flex"><div class="d-flex mr-auto"> <a class="logo navbar-brand" href="https://www.sierrasun.com"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/08/ss-logo-2x-1.png 2x" alt="SierraSun.com Logo" data-lazy-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/08/ss-logo-1.png"><noscript><img src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/08/ss-logo-1.png" srcset="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/08/ss-logo-2x-1.png 2x" alt="SierraSun.com Logo"></noscript> </a><div class="align-self-end"> <span class="tag-line navbar-text">Serving Truckee, Tahoe City, Kings Beach and Incline Village</span></div></div><div class="d-flex"><form class="search-form form-inline" action="https://www.sierrasun.com/search-results/"> <input class="search-input form-control" type="search" placeholder="Search" aria-label="Search" name="q"> <button class="search-button" type="submit"><i class="fas fa-search"></i></button> <input type="hidden" name="range" value="2019-11-08" /></form><ul class="nav-menu navbar-nav"><li class="nav-item"> <a class="nav-link" href="/forecast/"> <span class="current-weather-inline-ajax"></span> </a></li></ul></div></nav><nav id="nav-main" class="navbar navbar-expand d-none d-lg-flex"><div class="d-flex mr-auto"><div id="nav-main-menu"><ul class="nav-menu navbar-nav"><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-7" href="https://www.sierrasun.com/">News</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-7" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/news/business/">Business</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/news/cannabis/">Cannabis</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/news/community/">Community</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/news/crime/">Crime</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/news/housing/">Housing</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/news/education/">Education</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/news/environment/">Environment</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/news/fire/">Fire</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/news/health-wellness/">Health &#038; Wellness</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/news/politics/">Politics</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/news/obituaries/">Obituaries</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/news/weather/">Weather</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-156" href="https://www.sierrasun.com/opinion/">Opinion</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-156" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/opinion/columns/">Columns</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/contribute/guest-column/">Guest Column</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/opinion/letters-to-the-editor/">Letters to the Editor</a></li></ul><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-171" href="https://www.sierrasun.com/entertainment/">Entertainment</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-171" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/entertainment/activities-events/">Activities &#038; Events</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/entertainment/calendar/">Calendar</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.tahoedailytribune.com/podcasts/">Podcasts</a></li></ul><li class="nav-item "> <a class="nav-link " href="https://www.sierrasun.com/outdoors/">Outdoors</a></li><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-160" href="https://www.sierrasun.com/sports/">Sports</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-160" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/sports/community-sports/">Community Sports</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://www.sierrasun.com/sports/prep-sports/">Prep Sports</a></li></ul><li class="nav-item "> <a class="nav-link " href="https://www.sierrasun.com/videos/">Videos</a></li><li class="nav-item "> <a class="nav-link " href="https://www.sierrasun.com/magazines/">Magazines</a></li><li class="nav-item menu-item-has-children dropdown"> <a class="nav-link dropdown-object" id="menu-item-dropdown-130188" href="http://classifieds.sierrasun.com/">Classifieds</a><ul class="dropdown-menu shadow-sm" aria-labelledby="menu-item-dropdown-130188" role="menu"><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.sierrasun.com/category/Employment">Jobs</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.sierrasun.com/category/Real-Estate-For-Sale">Real Estate</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="http://classifieds.sierrasun.com/category/Transportation">Autos</a></li><li class="nav-item "> <a class="nav-link dropdown-item " href="https://secure.adpay.com/AdEntry.aspx?p=9189&publishId=ss">Place Ad</a></li></ul></li></ul></div></div><div class="d-flex"> <a href="https://www.sierrasun.com/support-community-journalism-in-tahoe/?utm_source=Website&utm_medium=Donate%20Button"><button class="sponsor-button btn " type="button">Donate <i class="fas fa-dollar-sign"></i></button></a></div></nav><nav id="nav-mobile" class="d-lg-none d-xl-none py-1 shadow-sm"><div class="d-flex justify-content-between align-items-center"><div class="m-3"> <button class="hamburger-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-menu" aria-controls="nav-mobile-menu" aria-expanded="false" aria-label="Toggle navigation"> <i class="fas fa-bars mr-1"></i> <i class="fas fa-times mr-1"></i> </button></div><div class="logo"> <a class="navbar-brand" href="https://www.sierrasun.com"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-srcset="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/08/ss-logo-2x-1.png 2x" alt="SierraSun.com Logo" data-lazy-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/08/ss-logo-1.png"><noscript><img src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/08/ss-logo-1.png" srcset="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/08/ss-logo-2x-1.png 2x" alt="SierraSun.com Logo"></noscript> </a></div><div class="m-3"> <button class="search-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-search" aria-controls="nav-mobile-search" aria-expanded="false" aria-label="Toggle search"> <i class="fas fa-search ml-1"></i> <i class="fas fa-times mr-1"></i> </button></div></div></nav><nav id="nav-mobile-menu" class="hamburger-button-dropdown collapse position-absolute shadow-sm d-lg-none d-xl-none"><ul class="nav-menu navbar-nav"><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-7" aria-expanded="false"> <span>News</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-7" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.sierrasun.com/">View Section ></a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/news/business/" >Business </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/news/cannabis/" >Cannabis </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/news/community/" >Community </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/news/crime/" >Crime </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/news/housing/" >Housing </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/news/education/" >Education </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/news/environment/" >Environment </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/news/fire/" >Fire </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/news/health-wellness/" >Health &#038; Wellness </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/news/politics/" >Politics </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/news/obituaries/" >Obituaries </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/news/weather/" >Weather </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-156" aria-expanded="false"> <span>Opinion</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-156" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.sierrasun.com/opinion/">View Section ></a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/opinion/columns/" >Columns </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/contribute/guest-column/" >Guest Column </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/opinion/letters-to-the-editor/" >Letters to the Editor </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-171" aria-expanded="false"> <span>Entertainment</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-171" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.sierrasun.com/entertainment/">View Section ></a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/entertainment/activities-events/" >Activities &#038; Events </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/entertainment/calendar/" >Calendar </a></li><li><a class="nav-link infant" href="https://www.tahoedailytribune.com/podcasts/" >Podcasts </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="https://www.sierrasun.com/outdoors/" > <span>Outdoors</span> </a></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-160" aria-expanded="false"> <span>Sports</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-160" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="https://www.sierrasun.com/sports/">View Section ></a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/sports/community-sports/" >Community Sports </a></li><li><a class="nav-link infant" href="https://www.sierrasun.com/sports/prep-sports/" >Prep Sports </a></li></ul></div></li><li class="nav-item"> <a class="nav-link" href="https://www.sierrasun.com/videos/" > <span>Videos</span> </a></li><li class="nav-item"> <a class="nav-link" href="https://www.sierrasun.com/magazines/" > <span>Magazines</span> </a></li><li class="nav-item"> <a class="nav-link" href="#" type="button" data-toggle="collapse" data-target="#sub-menu-130188" aria-expanded="false"> <span>Classifieds</span> <i class="fas fa-caret-right icon-caret"></i> </a><div id="sub-menu-130188" class="collapse sub-menu"><ul class="nav-menu navbar-nav"><li class="section"><a class="nav-link" href="http://classifieds.sierrasun.com/">View Section ></a></li><li><a class="nav-link infant" href="http://classifieds.sierrasun.com/category/Employment" >Jobs </a></li><li><a class="nav-link infant" href="http://classifieds.sierrasun.com/category/Real-Estate-For-Sale" >Real Estate </a></li><li><a class="nav-link infant" href="http://classifieds.sierrasun.com/category/Transportation" >Autos </a></li><li><a class="nav-link infant" href="https://secure.adpay.com/AdEntry.aspx?p=9189&publishId=ss" >Place Ad </a></li></ul></div></li><li class="nav-item"><a class="nav-link sponsor-button " type="button" href="https://www.sierrasun.com/support-community-journalism-in-tahoe/?utm_source=Website&utm_medium=Donate%20Button"><span>Donate</span></a></li></ul></nav><div id="nav-mobile-search" class="search-button-dropdown collapse position-absolute shadow-sm d-lg-none d-xl-none"><form class="search-form form-inline d-flex" action="https://www.sierrasun.com/search-results/"> <input class="search-input form-control flex-fill" type="search" aria-label="Search" name="q" placeholder="enter search terms"> <button class="search-button btn" type="submit">Search</button> <input type="hidden" name="range" value="2019-11-08" /></form></div></header><main><div class="container"><nav id="nav-reader-tools" class="navbar navbar-expand d-none d-lg-flex"><ul class="nav-menu navbar-nav ml-auto"><li id="menu-item-130193" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130193"><a href="https://edition.pagesuite.com/launch.aspx?pbid=3EE86800-0B96-47C1-92DA-DA9138AD31AA">E-Edition</a><span>|</span></li><li id="menu-item-130194" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130194"><a href="https://www.sierrasun.com/contribute/">Contribute</a><span>|</span></li><li id="menu-item-130195" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130195"><a href="http://www.swiftlocalsolutions.com/advertise-with-the-sierra-sun">Advertise</a><span>|</span></li><li id="menu-item-130196" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130196"><a href="https://secure.adpay.com/AdEntry.aspx?p=9189&#038;brand=SierraSun">Place an ad</a><span>|</span></li></ul></nav><div id="primary"><div class="container-fluid" style="margin-bottom: 20px;"><div class="row justify-content-center"><div id="ad-top" class="dfp"> <script>AdBridg.cmd.push(function() {
					AdBridg.display('ad-top');
				})</script> </div></div></div><div id="layout-single"><div class="d-lg-flex"><article class="flex-fill"><h1>Nevada County Board of Supervisor candidates make their case to voters</h1><div id="article-meta"><div class="row no-gutters"><div class="col-auto"><p class="article-meta"><a href="https://www.sierrasun.com/recent-stories/news">News</a> <span class="text-muted">| February 5, 2020</span></p></div><div class="col"><div class="d-lg-none"><div class="article-social"><ul class="nav"><li class="nav-item"> <a class="nav-link" href="https://twitter.com/intent/tweet?text=Nevada County Board of Supervisor candidates make their case to voters&url=https://www.sierrasun.com/?p=135367" target="_blank"><i class="fab fa-twitter icon-twitter"></i></a></li><li class="nav-item"> <a class="nav-link" href="https://www.facebook.com/dialog/share?app_id=969997716343864&href=https://www.sierrasun.com/news/nevada-county-board-of-supervisor-candidates-make-their-case-to-voters/" target="_blank"><i class="fab fa-facebook-f icon-facebook"></i></a></li><li class="nav-item"> <a class="nav-link fb-counter-link" href="https://www.facebook.com/dialog/share?app_id=969997716343864&href=https://www.sierrasun.com/news/nevada-county-board-of-supervisor-candidates-make-their-case-to-voters/" target="_blank"><span class="fb-counter">0</span></a></li><li class="nav-item d-none d-md-block"> <a class="nav-link" href="mailto:?subject=Nevada County Board of Supervisor candidates make their case to voters&body=Three candidates are looking to fill the Nevada County Board of Supervisors District 1 seat in the March 3 primary election. Incumbent Heidi Hall will face challengers Michael Taylor, building contractor; and Deborah Wilder, small...%0D%0A%0D%0Ahttps://www.sierrasun.com/news/nevada-county-board-of-supervisor-candidates-make-their-case-to-voters/"><i class="fas fa-envelope icon-email"></i></a></li><li class="nav-item d-none d-md-block"> <a class="nav-link" href="#" onclick="window.print();return false;"><i class="fas fa-print icon-printer"></i></a></li></ul></div></div></div></div></div><div id="article-byline"><div class="d-flex"> <strong><address>John Orona<br>Special to the Sierra Sun<br></address></strong><div class="d-none d-lg-block ml-auto"><div class="article-social"><ul class="nav"><li class="nav-item"> <a class="nav-link" href="https://twitter.com/intent/tweet?text=Nevada County Board of Supervisor candidates make their case to voters&url=https://www.sierrasun.com/?p=135367" target="_blank"><i class="fab fa-twitter icon-twitter"></i></a></li><li class="nav-item"> <a class="nav-link" href="https://www.facebook.com/dialog/share?app_id=969997716343864&href=https://www.sierrasun.com/news/nevada-county-board-of-supervisor-candidates-make-their-case-to-voters/" target="_blank"><i class="fab fa-facebook-f icon-facebook"></i></a></li><li class="nav-item"> <a class="nav-link fb-counter-link" href="https://www.facebook.com/dialog/share?app_id=969997716343864&href=https://www.sierrasun.com/news/nevada-county-board-of-supervisor-candidates-make-their-case-to-voters/" target="_blank"><span class="fb-counter">0</span></a></li><li class="nav-item d-none d-md-block"> <a class="nav-link" href="mailto:?subject=Nevada County Board of Supervisor candidates make their case to voters&body=Three candidates are looking to fill the Nevada County Board of Supervisors District 1 seat in the March 3 primary election. Incumbent Heidi Hall will face challengers Michael Taylor, building contractor; and Deborah Wilder, small...%0D%0A%0D%0Ahttps://www.sierrasun.com/news/nevada-county-board-of-supervisor-candidates-make-their-case-to-voters/"><i class="fas fa-envelope icon-email"></i></a></li><li class="nav-item d-none d-md-block"> <a class="nav-link" href="#" onclick="window.print();return false;"><i class="fas fa-print icon-printer"></i></a></li></ul></div></div></div></div><div class="p402_premium"> <script>jQuery(document).ready(function($) {
			    $('#imageGallery-135367-801').lightSlider({
			        gallery:true,
			        item:1,
			        loop:true,
			        thumbItem:9,
			        slideMargin:0,
							enableTouch:true,
			        enableDrag: false,
			        currentPagerPosition:'left',
			        onSliderLoad: function(el) {
								$( '.gallery-loading' ).hide();
								$( '.swift-gallery' ).css( 'opacity', 1 );
								/*var maxHeight = 0,
								container = $(el),
								children = container.children();
								children.each(function () {
									var childHeight = $(this).prop( 'scrollHeight' );
									if (childHeight > maxHeight) {
										maxHeight = childHeight;
									}
								});
								container.height(maxHeight);*/
			        }

			    });
			  });</script> <div class="row gallery-loading"><div class="col"><p class="text-center"><i class="fas fa-circle-notch fa-spin"></i></p></div></div><div class="swift-gallery p402_hide" style="opacity: 0;"><ul id="imageGallery-135367-801" class="gallery list-unstyled"><li data-thumb="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-150x150.jpg" data-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-1024x343.jpg" data-sub-html=" | " class="h-100"><div class="caption"><p><strong></strong><br/></p></div><div class="row no-gutters h-100"><div class="col my-auto"> <img src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-1024x343.jpg" data-no-lazy="1" alt="" /></div></div></li><li data-thumb="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-1-150x150.jpg" data-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-1.jpg" data-sub-html=" | Heidi Hall" class="h-100"><div class="caption"><p><strong>Heidi Hall</strong><br/></p></div><div class="row no-gutters h-100"><div class="col my-auto"> <img src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-1.jpg" data-no-lazy="1" alt="Heidi Hall" /></div></div></li><li data-thumb="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-2-150x150.jpg" data-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-2-768x1024.jpg" data-sub-html=" | Michael Taylor" class="h-100"><div class="caption"><p><strong>Michael Taylor</strong><br/></p></div><div class="row no-gutters h-100"><div class="col my-auto"> <img src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-2-768x1024.jpg" data-no-lazy="1" alt="Michael Taylor" /></div></div></li><li data-thumb="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-3-150x150.jpg" data-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-3-683x1024.jpg" data-sub-html=" | Deborah Wilder" class="h-100"><div class="caption"><p><strong>Deborah Wilder</strong><br/></p></div><div class="row no-gutters h-100"><div class="col my-auto"> <img src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-3-683x1024.jpg" data-no-lazy="1" alt="Deborah Wilder" /></div></div></li><li data-thumb="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-4-150x150.jpg" data-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-4-1024x667.jpg" data-sub-html="Elias Funez/efunez@theunion.com | From left, Supervisor Heidi Hall, Michael Taylor and Deborah Wilder are running for the District 1 seat on the Nevada County Board of Supervisors. They participated last month in a forum hosted by the League of Women Voters of Western Nevada County." class="h-100"><div class="caption"><p><strong>From left, Supervisor Heidi Hall, Michael Taylor and Deborah Wilder are running for the District 1 seat on the Nevada County Board of Supervisors. They participated last month in a forum hosted by the League of Women Voters of Western Nevada County.</strong><br/>Elias Funez/efunez@theunion.com</p></div><div class="row no-gutters h-100"><div class="col my-auto"> <img src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/ELECTIONSupesD1-GVU-020620-d-4-1024x667.jpg" data-no-lazy="1" alt="From left, Supervisor Heidi Hall, Michael Taylor and Deborah Wilder are running for the District 1 seat on the Nevada County Board of Supervisors. They participated last month in a forum hosted by the League of Women Voters of Western Nevada County." /></div></div></li></ul><p class="caption-toggle"><a href="#" class="show-captions">Show Captions</a><a href="#" class="hide-captions">Hide Captions</a></p></div><div class="swift-infobox alignleft p402_hide"><div class="module module-promo card shadow-sm"><div class="card-header"></div><div class="card-body"><p class="STND-STND Factbox Head">Learn More</p><p class="STND-STND Factbox Subhead">HALL</p><p class="STND-STND Factbox Text">Occupation: Nevada County supervisor, chairwoman of the board</p><p class="STND-STND Factbox Text">Age: 58</p><p class="STND-STND Factbox Text">Website: <a id="N0x19779b0N0x1b459f0:N0x19779b0N0x1994850" href="https://reelectheidihallsupervisor.org/">www.ReelectHeidiHallSupervisor.org</a></p><p class="STND-STND Factbox Text">Hometown: Nevada County</p><p class="STND-STND Factbox Text"/><p class="STND-STND Factbox Subhead">TAYLOR</p><p class="STND-STND Factbox Text">Occupation: General building contractor and private firefighter</p><p class="STND-STND Factbox Text">Age: 57</p><p class="STND-STND Factbox Text">Website: <a id="N0x19779b0N0x1b45bd0:N0x19779b0N0x1994bb0" href="https://mtaylor4district1.com/">www.mtaylor4district1.com</a></p><p class="STND-STND Factbox Text">Hometown: Nevada County</p><p class="STND-STND Factbox Text"/><p class="STND-STND Factbox Subhead">WILDER</p><p class="STND-STND Factbox Text">Occupation: Small business owner</p><p class="STND-STND Factbox Text">Age: 63</p><p class="STND-STND Factbox Text">Website: <a id="N0x19779b0N0x1b45db0:N0x19779b0N0x1994f10" href="https://wilderforsupervisor.com/">www.wilderforsupervisor.com</a></p><p class="STND-STND Factbox Text">Hometown: Oakland, CA</p></div></div></div><p class="STND-STND BodyText DropCap">Three candidates are looking to fill the Nevada County Board of Supervisors District 1 seat in the March 3 primary election. Incumbent Heidi Hall will face challengers Michael Taylor, building contractor; and Deborah Wilder, small business owner.</p><p class="STND-STND BodyText">Incumbent District 2 Supervisor Ed Scofield is running unopposed for his seat while Hardy Bullock is running unopposed for District 5, after incumbent Richard Anderson announced he would not seek reelection.</p><p class="STND-STND BodyText">If no candidate achieves at least 50% of the vote, plus one vote, the top two vote-getters will proceed to a November runoff.</p><div class="col-sm-12 text-center p402_hide"><div class="module-ad"><div id="ad-parallax2" class="dfp"> <script>AdBridg.cmd.push(function() {
					AdBridg.display('ad-parallax2');
				})</script> </div></div></div><p class="STND-STND BodyText Subhead">HEIDI HALL</p><p class="STND-STND BodyText">Heidi Hall is campaigning on the county’s accomplishments over the past three years, particularly in addressing homelessness and fire preparedness.</p><div class="col-sm-12 text-center p402_hide"><div class="module-ad"><div id="ad-big-box4" class="dfp"> <script>AdBridg.cmd.push(function() {
					AdBridg.display('ad-big-box4');
				})</script> </div></div></div><p class="STND-STND BodyText">“I believe I have been an effective and visionary supervisor in my three plus years on the board,” Hall said. “We have started new programs such as hiring a homelessness coordinator, funding the Fire Safe Council for increased vegetation clearing, purchasing property for a homeless resource center and transitional housing, implementing a cannabis ordinance, funding broadband expansion, investing in housing infrastructure and more. I am excited about taking them to the next stage, as well as refining our building and code compliance processes, and refreshing our role in economic development.”</p><p class="STND-STND BodyText">If reelected, Hall said she would continue prioritizing fire mitigation efforts while working on other issues critical to the county.</p><p class="STND-STND BodyText">“Clearly, more wildfire preparedness has to be a top priority, including increased vegetation clearing and work on evacuation routes and public awareness,” Hall said. “I will advocate for legislative fixes to our grave fire insurance crisis, promote improvements in our building and code processes, and continue to work for more affordable housing, homeless services, and additional cannabis business licenses.”</p><p class="STND-STND BodyText">According to Hall, who at a candidate forum signaled support for a tax to increase revenue for fire mitigation, county finances will have to be watched carefully.</p><p class="STND-STND BodyText">“I support our current unanimous approach for fiscal prudence, to make sure we can remain whole and continue to provide essential services to the entire county when the next recession hits,” Hall said. “I am an advocate of using our General Fund monies cautiously but wisely to invest, when possible, in programs that will pay themselves back via a better economy.”</p><p class="STND-STND BodyText Subhead">MICHAEL TAYLOR</p><p class="STND-STND BodyText">Michael Taylor said a lack of growth in Nevada County over the last decade in terms of housing, jobs and economic development led him to run for the supervisor seat and believes his experience in construction, logging, fire fighting and with cannabis farmers will allow him to offer industry friendly leadership.</p><p class="STND-STND BodyText">“I strongly believe that this stagnation has resulted in a lack of county general funds, which could’ve supported projects like a community senior center, expanded fire clearance and the establishment of a reliable power source,” Taylor said. “I’m concerned with the with a lack of healthy and smart growth.”</p><p class="STND-STND BodyText">According to Taylor, if elected he would focus on economic development and increasing the housing inventory, along with a focus on reorganizing the county’s cannabis and building permit processes to make them more streamlined.</p><p class="STND-STND BodyText">“I want to instill simple, streamlined (Community Development Agency) permitting processes and lower fees. I want to rebuild the community’s trust with the CDA so all projects, big or small will get permitted, will increase the CDA’s bottom line, raise housing inventory and raise the county’s assessed values,” Taylor said. “I also want to move cannabis permitting and oversight responsibilities to the Agriculture Department. I believe this industry will generate thousands, if not millions, of dollars of revenue for the county’s General Fund from permitting fees and taxes.”</p><p class="STND-STND BodyText">Taylor said he also supports encouraging staff to be more lenient and flexible in their interpretation of building codes to allow for more building to be permitted and wants the county to reevaluate its “rural owner-builder code,” Title 25, which other counties have used to encourage people in rural areas to build housing with less regulation.</p><p class="STND-STND BodyText">He also supports consolidating fire districts and wastewater districts to reduce overhead.</p><p class="STND-STND BodyText Subhead">DEBORAH WILDER</p><p class="STND-STND BodyText">Former Nevada County Republican Party Chairwoman Deborah Wilder said she hopes her experience as a business woman and emergency preparedness instructor will allow her to bring solutions to the county sooner than they have been delivered before.</p><p class="STND-STND BodyText">“I saw things in the county that didn’t seem to be getting done, so I decided to step up and spend the time needed to improve fire safety, homelessness and housing, internet service, senior issues and more,” Wilder said.</p><p class="STND-STND BodyText">Wilder said she would focus on emergency preparedness, vegetation management, evacuation plans and reinstating the Community Emergency Response Team program with the county in order to give people the ability to respond for themselves and their neighbors during a disaster situation. She said that same community-based approach is needed throughout the issues the county faces.</p><p class="STND-STND BodyText">“Some of the biggest challenges the county faces could be addressed through more community-based effort and solutions,” Wilder said. “Solutions for emergency preparedness can best be addressed by the county, the various fire agencies, the Firewise Council and the Fire Safety Council&#8230; all working together.”</p><p class="STND-STND BodyText">Unsatisfied with the timeline and practicality of some of the county’s more ambitious goals, such as a homeless resource center, Wilder said she would focus on supporting local organizations to provide housing and other homelessness services.</p><p class="STND-STND BodyText">“I would rather find a way to help those nonprofits who are already doing a good job of housing and providing services to the homeless to expand those services,” Wilder said. “Maybe that includes providing access to county buildings not in use, or an expedited building protocol for new construction or expansion or a low cost loan. Maybe temporary trailers could be used to house the initial homeless resource center. This is faster and cheaper than the current county plan.”</p><p class="STND-STND BodyText Tagline">To contact Staff Writer John Orona, email <a href="mailto:jorona@theunion.com">jorona@theunion.com</a> or call 530-477-4229.</p></div> <script type="text/javascript">try { _402_Show(); } catch(e) {}</script> <hr /><style>.ssu-donation{text-align:center}.ssu-donation .logo{width:50%;margin:1rem 0 1rem}.ssu-donation h1{font-size:2rem}.ssu-donation hr{width:20%;border-top:4px solid #000}.ssu-donation .btn{background-color:#5abb89!important;padding:.4rem 1.5rem}.ssu-donation .btn:hover{background-color:#f1a862!important}@media (min-width:768px){.ssu-donation .logo{width:35%}}@media (min-width:1440px){.ssu-donation{text-align:left}.ssu-donation hr{margin-left:0}}</style><div class="row ssu-donation"><div class="col-xl-4"> <a href="https://www.sierrasun.com/support-community-journalism-in-tahoe/?utm_source=Website&utm_medium=Article%20CTA&utm_campaign=donation"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/12/ssu-donation-image.jpg" /><noscript><img src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/12/ssu-donation-image.jpg" /></noscript></a></div><div class="col-xl-8"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="logo" data-lazy-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/08/ss-logo-2x-1.png" /><noscript><img src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/08/ss-logo-2x-1.png" class="logo" /></noscript><h1>Support Local Journalism</h1><hr /><p><strong>Your support means a better informed community.</strong></p> <button class="btn" type="button"><a href="https://www.sierrasun.com/support-community-journalism-in-tahoe/?utm_source=Website&utm_medium=Article%20CTA&utm_campaign=donation">Donate</a></button></div></div><hr /><div class="fb-comments" data-href="https://www.sierrasun.com/?p=135367" data-width="100%" data-numposts="3"></div><div class="row"><div class="card-item col-md-12"><div class="module module-dual-column card shadow-sm"><div class="card-header"><i class="far fa-newspaper icon-section"></i> News</div><div class="card-body"><section><article><div class="row no-gutters"><div class="col-12 col-lg-5 card-img featured text-center"> <a href="https://www.sierrasun.com/news/local/south-lake-tahoes-snowglobe-sued-for-excessive-levels-of-cancer-causing-benzene/"><img width="300" height="169" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20169'%3E%3C/svg%3E" class="attachment-medium size-medium wp-post-image" alt="" data-lazy-srcset="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SnowGlobe-act-122719-1-300x169.jpg 300w, https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SnowGlobe-act-122719-1-1024x576.jpg 1024w, https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SnowGlobe-act-122719-1-768x432.jpg 768w, https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SnowGlobe-act-122719-1-1536x865.jpg 1536w, https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SnowGlobe-act-122719-1-2048x1153.jpg 2048w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SnowGlobe-act-122719-1-300x169.jpg" /><noscript><img width="300" height="169" src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SnowGlobe-act-122719-1-300x169.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SnowGlobe-act-122719-1-300x169.jpg 300w, https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SnowGlobe-act-122719-1-1024x576.jpg 1024w, https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SnowGlobe-act-122719-1-768x432.jpg 768w, https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SnowGlobe-act-122719-1-1536x865.jpg 1536w, https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SnowGlobe-act-122719-1-2048x1153.jpg 2048w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></div><div class="col-12 col-lg-7 card-text"><h4><a href="https://www.sierrasun.com/news/local/south-lake-tahoes-snowglobe-sued-for-excessive-levels-of-cancer-causing-benzene/">South Lake Tahoe’s SnowGlobe sued for excessive levels of cancer-causing benzene</a></h4><p class="card-meta"> <span class="text-muted">February 6, 2020</span></p><p class="card-excerpt d-lg-none d-xl-block"></p></div></div></article><hr /><div class="row"><div class="col col-hero"><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.sierrasun.com/news/local/humane-society-of-truckee-tahoe-chosen-for-jackson-galaxy-projects-cat-pawsitive-program/"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/HumaneSociety-SSU-020720-A-150x150.jpg" /><noscript><img width="150" height="150" src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/HumaneSociety-SSU-020720-A-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.sierrasun.com/news/local/humane-society-of-truckee-tahoe-chosen-for-jackson-galaxy-projects-cat-pawsitive-program/">Humane Society of Truckee-Tahoe chosen for Jackson Galaxy Project’s Cat Pawsitive program</a></h6><p class="card-meta"> <span class="text-muted">February 6, 2020</span></p></div></div></article><hr /><article><div class="row no-gutters"><div class="col card-text"><h6><a href="https://www.sierrasun.com/news/superintendent-chief-learning-officer-leri-retiring-from-tahoe-truckee-unified-school-district/">Superintendent Chief Learning Officer Rob Leri retiring from Tahoe Truckee Unified School District</a></h6><p class="card-meta"> <span class="text-muted">February 6, 2020</span></p></div></div></article><hr class="d-md-none d-lg-none d-xl-none" /></div><div class="col col-hero"><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.sierrasun.com/news/man-arrested-after-twice-fleeing-from-south-lake-tahoe-pd-one-suspect-still-on-run/"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="hendrickson-PD-arrest-2" data-lazy-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/hendrickson-PD-arrest-2-150x150.jpg" /><noscript><img width="150" height="150" src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/hendrickson-PD-arrest-2-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="hendrickson-PD-arrest-2" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.sierrasun.com/news/man-arrested-after-twice-fleeing-from-south-lake-tahoe-pd-one-suspect-still-on-run/">Man arrested after twice fleeing from South Lake Tahoe PD; one suspect still on run</a></h6><p class="card-meta"> <span class="text-muted">February 5, 2020</span></p></div></div></article><hr /><article><div class="row no-gutters"><div class="col-3 card-img"> <a href="https://www.sierrasun.com/news/north-tahoes-aj-hurt-skis-to-first-nor-am-cup-win-of-season/"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" data-lazy-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SkiWrap-SSU-020720-2-150x150.jpg" /><noscript><img width="150" height="150" src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2020/02/SkiWrap-SSU-020720-2-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></noscript></a></div><div class="col card-text"><h6><a href="https://www.sierrasun.com/news/north-tahoes-aj-hurt-skis-to-first-nor-am-cup-win-of-season/">North Tahoe&#8217;s AJ Hurt skis to first Nor-Am Cup win of season</a></h6><p class="card-meta"> <span class="text-muted">February 4, 2020</span></p></div></div></article></div></div><hr /></section> <a href="https://www.sierrasun.com/recent-stories/news/" class="card-link card-more">See more <i class="fas fa-angle-right"></i></a></div></div></div></div><hr /><div id="single-flipp-script"><div id="circularhub_module_15513"></div><div class="js-lazy-script" data-src="//api.circularhub.com/15513/1d2888567fe3eff6/circularhub_module.js"></div></div></article><aside><div class="card-container row"><div class="card-item col-sm-12 text-center"><div class="module-ad ad-big-box1"><div id="ad-big-box1" class="dfp"> <script>AdBridg.cmd.push(function() {
AdBridg.display('ad-big-box1');
})</script> </div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-gallery module-c2 card shadow-sm"><div class="card-header"></div><div class="card-body"><h5 class="card-title">Top Jobs</h5><div id="carousel-130158" class="carousel slide" data-ride="carousel" data-interval="false"><div class="carousel-inner"><div class="carousel-item active" style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.sierrasun.com/ad/Employment/Services/journeyman-electrician-apprentice-electrician-ac-electric-truckee/7-0000546133-01" target="_blank" style="display:block;overflow:hidden;"><h5>AC Electric</h5><h6 style="color:#000;">Journeyman Electrician/ Apprentice Electrician at AC Electric in TRUCKEE</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>AC Electric Now Hiring Journeyman &amp; Apprentice Electricians working in Northlake Tahoe, Truckee and Reno&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.sierrasun.com/ad/Employment/Health-Care/lateral-firefighterparamedic-truckee-fire-protection-district-truckee/7-0000545911-01" target="_blank" style="display:block;overflow:hidden;"><h5>Truckee Fire Protection District</h5><h6 style="color:#000;">Lateral Firefighter/Paramedic at Truckee Fire Protection District in TRUCKEE</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>The Truckee Fire Protection District is accepting applications for the position of Lateral Firefighter&#47;Paramedic. For&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.sierrasun.com/ad/Employment/Hospitality/cook-harrahs-tahoe-harveys-tahoe-casino-stateline/7-0000545019-01" target="_blank" style="display:block;overflow:hidden;"><h5>Harrah's Tahoe/ Harvey's Tahoe Casino</h5><h6 style="color:#000;">Cook at Harrah's Tahoe/ Harvey's Tahoe Casino in STATELINE</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>$1,000 Hiring Bonus! * Do you have what it takes to cook with the best&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.sierrasun.com/ad/Employment/Government/utilities-operations-specialist-i-or-ii-doq-tahoe-city-public-utility-district-tahoe-city/7-0000549648-01" target="_blank" style="display:block;overflow:hidden;"><h5>TAHOE CITY PUBLIC UTILITY DISTRICT</h5><h6 style="color:#000;">Utilities Operations Specialist I or II (DOQ) at TAHOE CITY PUBLIC UTILITY DISTRICT in TAHOE CITY</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>Utilities Operations Specialist I or II (DOQ) and the full time, seasonal position of Utilities&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.sierrasun.com/ad/Employment/Government/interim-district-attorney-county-of-placer-rocklin/7-0000542536-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Interim District Attorney at County of Placer in ROCKLIN" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;" data-lazy-src="https://classifieds.sierrasun.com/data/thumbnails/t_0000542536-01-0.jpg"><noscript><img class="slide-image" src="https://classifieds.sierrasun.com/data/thumbnails/t_0000542536-01-0.jpg" alt="Interim District Attorney at County of Placer in ROCKLIN" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></noscript></a><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.sierrasun.com/ad/Employment/Government/interim-district-attorney-county-of-placer-rocklin/7-0000542536-01" target="_blank" style="display:block;overflow:hidden;"><h5>County of Placer</h5><h6 style="color:#000;">Interim District Attorney at County of Placer in ROCKLIN</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>The Placer County District Attorney retired effective December 30, 2019, resulting in a vacancy in&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.sierrasun.com/ad/Employment/Customer-Service/customer-service-representative-full-and-part-time-positions-nevada-news-group-carson-city/7-0000536974-01" target="_blank" style="display:block;overflow:hidden;"><h5>Nevada News Group</h5><h6 style="color:#000;">Customer Service Representative - Full & Part time positions at Nevada News Group in CARSON CITY</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span></span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"> <a href="http://classifieds.sierrasun.com/ad/Employment/Government/census-takers-us-census/7-0000544567-01" target="_blank" style="display: block;max-width: 75px;float:left;margin-right: 10px;"><img class="slide-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Census Takers at U.S. Census" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;" data-lazy-src="https://classifieds.sierrasun.com/data/thumbnails/t_0000544567-01.jpg"><noscript><img class="slide-image" src="https://classifieds.sierrasun.com/data/thumbnails/t_0000544567-01.jpg" alt="Census Takers at U.S. Census" style="margin: 0 auto 4px auto;width: auto;max-height: 100px;"></noscript></a><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.sierrasun.com/ad/Employment/Government/census-takers-us-census/7-0000544567-01" target="_blank" style="display:block;overflow:hidden;"><h5>U.S. Census</h5><h6 style="color:#000;">Census Takers at U.S. Census</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>2020 Cenus is HIRING Become A Census Taker at $18&#47;hr Excellent Pay, flexible hours, no&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.sierrasun.com/ad/Employment/Automotive/automotive-technician-mechanic-eloise-automotive-and-alignment-south-lake-tahoe/7-0000546790-01" target="_blank" style="display:block;overflow:hidden;"><h5>Eloise Automotive & Alignment</h5><h6 style="color:#000;">Automotive Technician/ Mechanic at Eloise Automotive & Alignment in SOUTH LAKE TAHOE</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>Now Hiring. Eloise Automotive &amp; Alignment is looking for the right person to fill a&hellip;</span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.sierrasun.com/ad/Employment/Customer-Service/customer-service-representative-full-and-part-time-positions-nevada-news-group-carson-city/7-0000541085-01" target="_blank" style="display:block;overflow:hidden;"><h5>Nevada News Group</h5><h6 style="color:#000;">Customer Service Representative - Full & Part time positions at Nevada News Group in CARSON CITY</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span></span></p> </a></div></div><div class="carousel-item " style="overflow:hidden;padding-left: 20px;"><div class="card-content" style="max-width:220px;float:left;"> <a href="http://classifieds.sierrasun.com/ad/Employment/Government/utilities-operations-specialist-i-or-ii-doq-tahoe-city-public-utility-district-tahoe-city/7-0000549629-01" target="_blank" style="display:block;overflow:hidden;"><h5>Tahoe City Public Utility District</h5><h6 style="color:#000;">Utilities Operations Specialist I or II (DOQ) at Tahoe City Public Utility District in TAHOE CITY</h6><p style="font-size:.875rem;color:#000;"> <em></em><br><span>Utilities Operations Specialist I or II (DOQ) and the full time, seasonal position of Utilities&hellip;</span></p> </a></div></div></div><div class="carousel-nav d-flex justify-content-center"> <a class="carousel-control-prev position-absolute" style="width:60px;height:40px;top:100px;left:-30px;" href="#carousel-130158" role="button" data-slide="prev"> <i class="fas fa-chevron-left"></i> <span class="sr-only">Previous</span> </a><ol class="carousel-indicators position-relative"><li data-target="#carousel-130158" data-slide-to="1" class="active"></li><li data-target="#carousel-130158" data-slide-to="2" class=""></li><li data-target="#carousel-130158" data-slide-to="3" class=""></li><li data-target="#carousel-130158" data-slide-to="4" class=""></li><li data-target="#carousel-130158" data-slide-to="5" class=""></li><li data-target="#carousel-130158" data-slide-to="6" class=""></li><li data-target="#carousel-130158" data-slide-to="7" class=""></li><li data-target="#carousel-130158" data-slide-to="8" class=""></li><li data-target="#carousel-130158" data-slide-to="9" class=""></li><li data-target="#carousel-130158" data-slide-to="10" class=""></li></ol> <a class="carousel-control-next position-absolute" style="width:60px;height:40px;top:100px;right:-30px;" href="#carousel-130158" role="button" data-slide="next"> <i class="fas fa-chevron-right"></i> <span class="sr-only">Next</span> </a></div></div><hr /> <a href="http://classifieds.sierrasun.com/category/Employment" class="card-link card-more" target="_blank">View more listings <i class="fas fa-angle-right"></i></a></div></div></div><div class="card-item col-sm-12 text-center"><div class="module-ad ad"><div id="ad-big-box2" class="dfp"> <script>AdBridg.cmd.push(function() {
AdBridg.display('ad-big-box2');
})</script> </div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-e-edition card shadow-sm"><div class="card-header"><i class="fas fa-book-reader"></i> Sierra Sun E-Edition</div><div class="card-body"><section> <iframe src="https://edition.pagesuite.com/miniflip/default.aspx?w=150&pages=8&autoflip=4000&PBID=3ee86800-0b96-47c1-92da-da9138ad31aa" style="border: none;"></iframe></section></div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-html card shadow-sm"><div class="card-header"></div><div class="card-body"><h5 class="card-title">Events</h5><hr /><p><script src="https://northshore.spingo.com/list-widget.js"></script></p><div id="spingo-list-widget"></div><p><script>new SpinGoWidget({
  	title: "Sierra Sun",
        perPage: 2
  });</script></p></div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-html card shadow-sm"><div class="card-header"></div><div class="card-body"><h5 class="card-title">Recent Poll</h5><hr /><p><div id="polls-31" class="wp-polls"><form id="polls_form_31" class="wp-polls-form" action="/index.php" method="post"><p style="display: none;"><input type="hidden" id="poll_31_nonce" name="wp-polls-nonce" value="004b322513" /></p><p style="display: none;"><input type="hidden" name="poll_id" value="31" /></p><p style="text-align: center;"><strong>How should eastern Nevada County reduce traffic congestion during peak tourism?</strong></p><div id="polls-31-ans" class="wp-polls-ans"><ul class="wp-polls-ul"><li><input type="radio" id="poll-answer-112" name="poll_31" value="112" /> <label for="poll-answer-112">Stop advertising</label></li><li><input type="radio" id="poll-answer-113" name="poll_31" value="113" /> <label for="poll-answer-113">Put “locals only” signs by residential streets</label></li><li><input type="radio" id="poll-answer-114" name="poll_31" value="114" /> <label for="poll-answer-114">Provide shuttles from Park n Rides to events</label></li><li><input type="radio" id="poll-answer-115" name="poll_31" value="115" /> <label for="poll-answer-115">None of the above. We chose to live here and everything that comes with it.</label></li></ul><p style="text-align: center;"><input type="button" name="vote" value=" Vote " class="Buttons" onclick="poll_vote(31);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(31); return false;" title="View Results Of This Poll">View Results</a></p></div></form></div><div id="polls-31-loading" class="wp-polls-loading"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2016%2016'%3E%3C/svg%3E" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" data-lazy-src="https://cdn.sierrasun.com/wp-content/plugins/wp-polls/images/loading.gif" /><noscript><img src="https://cdn.sierrasun.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" /></noscript>&nbsp;Loading ...</div></p></div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-weather card shadow-sm"><div class="card-header"><i class="wi wi-day-sunny"></i> 5-Day Forecast</div><div class="card-body"><div class="row"><div class="col text-center"> <i class="wi wi-fog"></i><p><strong>Thu</strong><br /> <span class="card-meta">H: 50&deg;<br /> L: 26&deg;</span><br /></p></div><div class="col text-center"> <i class="wi wi-day-sunny"></i><p><strong>Fri</strong><br /> <span class="card-meta">H: 54&deg;<br /> L: 23&deg;</span><br /></p></div><div class="col text-center"> <i class="wi wi-day-sunny"></i><p><strong>Sat</strong><br /> <span class="card-meta">H: 50&deg;<br /> L: 25&deg;</span><br /></p></div><div class="col text-center"> <i class="wi wi-day-cloudy"></i><p><strong>Sun</strong><br /> <span class="card-meta">H: 37&deg;<br /> L: 22&deg;</span><br /></p></div><div class="col text-center"> <i class="wi wi-day-sunny"></i><p><strong>Mon</strong><br /> <span class="card-meta">H: 44&deg;<br /> L: 18&deg;</span><br /></p></div></div><hr /><a href="https://www.sierrasun.com/forecast/" class="card-link card-more">See more <i class="fas fa-angle-right"></i></a></div></div></div><div class="card-item col-sm-12 col-md-6 col-lg-12"><div class="module module-promo card shadow-sm"><div class="card-header"><i class="fas fa-info-circle"></i> See the Winners!</div><div class="card-body"><div class="text-center"> <a href="https://www.sierrasun.com/best-of-north-tahoe-best-of-truckee-2019/#//" ><img width="300" height="250" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20250'%3E%3C/svg%3E" class="attachment-full size-full" alt="" data-lazy-src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/04/407257-300x250-winners-1.jpg" /><noscript><img width="300" height="250" src="https://cdn.sierrasun.com/wp-content/uploads/sites/4/2019/04/407257-300x250-winners-1.jpg" class="attachment-full size-full" alt="" /></noscript></a></div></div></div></div><div class="card-item col-12 module-video-section"><div id="video-carousel-5e3c765d50011" data-interval="0" class="video-carousel carousel slide"><div class="module module-video module-dark card shadow-sm"><div class="card-header"><i class="fas fa-video icon"></i> Recent Videos</div><div class="card-body"><div class="carousel-inner"><div class="carousel-item active"><div class="video-item"><div id="vid-it-5e3c765d4e9f9"><div style="position: relative; padding-bottom: 56.25%; height: 0px; width: 100%; box-sizing: content-box;"> <iframe allowfullscreen allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" scrolling="no" src="https://player.swiftcom.com?v=DHys4pcpNE8&refurl=&refhost=www.sierrasun.com" style="border: 0; width: 100%; height: 100%; position: absolute; display: block;"></iframe></div></div></div><h4><a href="https://www.sierrasun.com/sports/incline-makes-statement-with-rivalry-win-at-north-tahoe/">Incline makes statement with rivalry win at North Tahoe</a></h4><p class="card-meta"> <span class="text-muted">January 15, 2020</span></p><p class="card-excerpt">The gym at North Tahoe High School was packed Tuesday night for the rivalry game between the Lakers and league foe Incline. The matchup featured the top two teams in the Class 2A Northern League,...</p></div><div class="carousel-item "><div class="video-item"><div id="vid-it-5e3c765d4f973"><div style="position: relative; padding-bottom: 56.25%; height: 0px; width: 100%; box-sizing: content-box;"> <iframe allowfullscreen allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" scrolling="no" src="https://player.swiftcom.com?v=X4ENx-5-xmw&refurl=&refhost=www.sierrasun.com" style="border: 0; width: 100%; height: 100%; position: absolute; display: block;"></iframe></div></div></div><h4><a href="https://www.sierrasun.com/news/70th-warren-miller-ski-film-screens-friday-saturday-by-resort-at-squaw-creek/">VIDEO: 70th Warren Miller ski film screens Friday, Saturday by Resort at Squaw Creek</a></h4><p class="card-meta"> <span class="text-muted">October 30, 2019</span></p><p class="card-excerpt">Year after year, skiers and snowboarders of all ages look forward to the coming of winter, and for many that =also means the latest Warren Miller ski film. On Friday and Saturday, the Resort at...</p></div></div><div class="carousel-nav d-flex justify-content-center"> <a class="carousel-control-prev" href="#video-carousel-5e3c765d50011" role="button" data-slide="prev"> <i class="fas fa-angle-left"></i> <span class="sr-only">Previous</span> </a><ol class="carousel-indicators position-relative"><li data-target="#video-carousel" data-slide-to="0" class="active"></li><li data-target="#video-carousel" data-slide-to="1" class=""></li></ol> <a class="carousel-control-next" href="#video-carousel-5e3c765d50011" role="button" data-slide="next"> <i class="fas fa-angle-right"></i> <span class="sr-only">Next</span> </a></div><hr /><a href="https://www.sierrasun.com/videos/" class="card-link card-more">More videos <i class="fas fa-angle-right"></i></a></div></div></div></div></div></aside></div></div></div></div></main><nav id="nav-mobile-footer" class="fixed-bottom d-lg-none d-xl-none"><ul class="nav nav-fill"><li class="nav-item"> <a class="nav-link " href="https://www.sierrasun.com"><i class="fas fa-home icon"></i><br/>Home</a></li><li class="nav-item"> <a class="nav-link " href="https://www.sierrasun.com/trending-stories/news/"><i class="fas fa-chart-line icon"></i><br/>Trending</a></li><li class="nav-item"> <a class="nav-link" id="mobile-back-to-top" href="#" class="hamburger-button collapsed" type="button" data-toggle="collapse" data-target="#nav-mobile-menu" aria-controls="nav-mobile-menu" aria-expanded="false" aria-label="Toggle navigation"><i class="fas fa-bars icon"></i><br/>Sections</a></li></ul></nav><footer><div class="container"><nav id="nav-footer"><div class="row"><div class="col-md-5 offset-md-1 order-md-4"><ul class="nav nav-social justify-content-center justify-content-md-end"><li class="nav-item"><a class="nav-link" href="https://twitter.com/SierraSunNews" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-twitter icon-circle"></i> <i class="fab fa-twitter fa-stack-1x icon-social"></i> </span></a></li><li class="nav-item"><a class="nav-link" href="https://www.facebook.com/SierraSun1" target="_blank"> <span class="fa-stack fa-2x"> <i class="fas fa-circle fa-stack-2x bg-facebook-f icon-circle"></i> <i class="fab fa-facebook-f fa-stack-1x icon-social"></i> </span></a></li></ul></div><div class="col-md-2 nav-list order-md-1"><h6>Marketplace</h6><div class="nav"><div class="row"><div class="col-6 col-lg-12"><p class="menu-item"> <a href="http://classifieds.sierrasun.com/category/Employment">Jobs</a></p><p class="menu-item"> <a href="http://classifieds.sierrasun.com/">Classifieds</a></p><p class="menu-item"> <a href="http://classifieds.sierrasun.com/category/Transportation">Autos</a></p><p class="menu-item"> <a href="http://classifieds.sierrasun.com/category/Real+Estate+For+Sale">Real Estate</a></p><p class="menu-item"> <a href="http://classifieds.sierrasun.com/category/Rentals">Rentals</a></p><p class="menu-item"> <a href="http://classifieds.sierrasun.com/category/Business+and+Service+Directory">Service Directory</a></p><p class="menu-item"> <a href="http://classifieds.sierrasun.com/category/Pets">Pets</a></p></div><div class="col-6 col-md-12"><p class="menu-item"> <a href="http://classifieds.sierrasun.com/category/Merchandise">Merchandise</a></p><p class="menu-item"> <a href="http://classifieds.sierrasun.com/category/Legals">Legals</a></p><p class="menu-item"> <a href="http://classifieds.sierrasun.com/category/Livestock+and+Animals">Farm & Ranch</a></p><p class="menu-item"> <a href="http://classifieds.sierrasun.com/category/Recreation">Recreation</a></p><p class="menu-item"> <a href="http://classifieds.sierrasun.com/category/Announcements">Announcements</a></p></div></div></div></div><div class="col-md-2 nav-list order-md-2"><h6>Reader Tools</h6><div class="nav"><div class="row"><div class="col-6 col-lg-12"><p class="menu-item"> <a href="https://www.sierrasun.com/contact-us/">Contact Us</a></p><p class="menu-item"> <a href="https://www.sierrasun.com/contribute/">Contribute</a></p><p class="menu-item"> <a href="http://www.swiftlocalsolutions.com/advertise-with-the-sierra-sun">Advertise</a></p><p class="menu-item"> <a href="https://www.sierrasun.com/search-results/">Archives</a></p><p class="menu-item"> <a href="http://sierrasun.secondstreetapp.com/Newsletter-Sign-up-Page/">Newsletters</a></p></div><div class="col-6 col-md-12"><p class="menu-item"> <a href="https://www.sierrasun.com/news/special-sections/">Special Sections</a></p><p class="menu-item"> <a href="https://www.sierrasun.com/feed/">RSS</a></p><p class="menu-item"> <a href="http://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&pubid=3ee86800-0b96-47c1-92da-da9138ad31aa">Sierra Sun E-Edition</a></p><p class="menu-item"> <a href="http://edition.pagesuite-professional.co.uk/html5/reader/production/default.aspx?pubname=&pubid=50a590f1-fdb1-46b5-885e-93c888c77b7a">Real Estate E-Edition</a></p></div></div></div></div><div class="col-md-2 nav-list order-md-3"><h6>News Neighbors</h6><div class="nav"><div class="row"><div class="col-6 col-lg-12"><p class="menu-item"> <a href="https://www.tahoedailytribune.com/">Tahoe Daily Tribune</a></p><p class="menu-item"> <a href="https://www.nevadaappeal.com/">Carson City - Nevada</a></p><p class="menu-item"> <a href="https://www.recordcourier.com/">Gardenerville- Nevada</a></p></div><div class="col-6 col-md-12"><p class="menu-item"> <a href="https://www.theunion.com/">Grass Valley - California</a></p><p class="menu-item"> <a href="https://www.nnbusinessview.com/">Northern Nevada Business View</a></p></div></div></div></div></div></nav><nav id="nav-footer-sub"><ul class="nav justify-content-center"><li id="menu-item-130199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130199"><a href="https://www.sierrasun.com/about-us/">About Us</a><span>|</span></li><li id="menu-item-130200" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130200"><a href="https://cdn.sierrasun.com/wp-content/uploads/2016/08/AdvertisingTermsandConditions09-12-11.pdf">Terms &#038; Conditions</a><span>|</span></li><li id="menu-item-130201" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130201"><a href="https://www.sierrasun.com/terms-of-use/">Terms of Use</a><span>|</span></li><li id="menu-item-130202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130202"><a href="https://www.sierrasun.com/privacy-policy/">Privacy Policy</a><span>|</span></li></ul><p class="text-center text-muted">©2005 - 2020 Swift Communications, Inc.</p></nav></div></footer> <script async src="https://www.googletagmanager.com/gtag/js?id=AW-1066460699"></script> <script>window.dataLayer = window.dataLayer || [];
					  function gtag(){dataLayer.push(arguments);}
					  gtag('js', new Date());
					  gtag('config', 'AW-1066460699');</script> <script>jQuery(function($) {
						if ( $( '.wp-audio-shortcode' ).length ) {
							$( 'audio' ).mediaelementplayer({
								success: function(mediaElement, domObject, instance) {
		        			mediaElement.addEventListener('loadeddata', function() {
										ga( 'send', 'event', 'audio', 'play' );
										ga( 'newTracker.send', 'event', 'audio', 'play' );
				        	}, false);
									mediaElement.addEventListener('loadstart', function() {
										$( '.mejs-audio a.audio-download' ).click(function() {
											ga( 'send', 'event', 'audio', 'download' );
											ga( 'newTracker.send', 'event', 'audio', 'download' );
										});
									}, false);
		  					}
							});
						}
					});</script> <script>jQuery(function($) {
						$( '#mobile-app-link' ).click(function () {
							var eventLabel = $(this).attr('title');
							ga( 'send', 'event', 'Mobile App Link', 'Click', eventLabel );
							ga( 'newTracker.send', 'event', 'Mobile App Link', 'Click', eventLabel );
						});
					});</script> <link rel="manifest" href="https://cdn.sierrasun.com/manifest.json" /> <script src="https://cdn.p-n.io/pushly-sdk.min.js" async></script> <script>var PushlySDK = window.PushlySDK || [];
					function pushly() { PushlySDK.push(arguments) }
					pushly('load', {
						domainKey: 'QLrBD21OwJ6lA9kCpFyoJJsYDWzI4zdOE840',
					});</script> <link rel="manifest" href="https://cdn.sierrasun.com/manifest.json" /> <script src="https://cdn.p-n.io/pushly-sdk.min.js" async></script> <script>var PushlySDK = window.PushlySDK || [];
					function pushly() { PushlySDK.push(arguments) }
					pushly('load', {
						domainKey: 'QLrBD21OwJ6lA9kCpFyoJJsYDWzI4zdOE840',
					});</script><script type='text/javascript'>/* <![CDATA[ */ var pollsL10n = {"ajax_url":"https:\/\/www.sierrasun.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"}; /* ]]> */</script> <script type='text/javascript' src='https://cdn.sierrasun.com/wp-content/cache/busting/4/wp-content/plugins/wp-polls/polls-js-2.75.4.js'></script> <script type='text/javascript' src='https://cdn.sierrasun.com/wp-content/cache/busting/4/wp-content/themes/swift-news-theme/assets/js/vendors/popper-1.14.3.js'></script> <script type='text/javascript' src='https://cdn.sierrasun.com/wp-content/cache/busting/4/wp-content/themes/swift-news-theme/assets/js/vendors/bootstrap-4.4.1.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var more_briefs = {"ajaxurl":"https:\/\/www.sierrasun.com\/wp-admin\/admin-ajax.php","briefs_nonce":"318067a16f"};
var current_weather_inline_ajax = {"ajaxurl":"https:\/\/www.sierrasun.com\/wp-admin\/admin-ajax.php","current_weather_inline_ajax_nonce":"fed5a5f47b"};
var current_weather_ajax = {"ajaxurl":"https:\/\/www.sierrasun.com\/wp-admin\/admin-ajax.php","current_weather_ajax_nonce":"d6d5b13714"}; /* ]]> */</script> <script type='text/javascript' async="async" src='https://cdn.sierrasun.com/wp-content/cache/busting/4/wp-content/themes/swift-news-theme/assets/js/main-1580154974.js'></script> <script type='text/javascript' src='https://cookie-cdn.cookiepro.com/consent/deabe036-ca00-423b-8255-0d58b2ba02f9.js?ver=1.0'></script> <script type='text/javascript'>function OptanonWrapper() { }</script> <script type='text/javascript' src='https://cdn.sierrasun.com/wp-content/cache/busting/4/wp-content/themes/swift-news-theme/assets/js/vendors/lightslider-1.1.6.js'></script> <script type='text/javascript' src='https://cdn.sierrasun.com/wp-content/cache/busting/4/wp-content/themes/swift-news-theme/assets/js/vendors/lightgallery-1.6.11.js'></script> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.5.6/jquery.fancybox.min.js?ver=3.5.6'></script> <script type='text/javascript' src='https://cdn.sierrasun.com/wp-includes/js/wp-embed.min.js'></script> <script>var loggedIn = 'no';
var swiftLanguage = ( accessCookie("swift_language") == null ) ? 'english' : accessCookie("swift_language");
ga('set', {'dimension1': 'News','dimension2': 'None','dimension3': 'News/None','dimension5': loggedIn,'dimension6': 'John Orona','dimension7': '','dimension8': '2020-02-05','dimension9': '39475061','dimension10': '','dimension12': '2020-02-05 19:17:00','dimension13': '18','dimension14': 'article','dimension15': '971','dimension16': 'featured','dimension18': swiftLanguage});
ga('newTracker.set', {'dimension1': 'News','dimension2': 'None','dimension3': 'News/None','dimension5': loggedIn,'dimension6': 'John Orona','dimension7': '','dimension8': '2020-02-05','dimension9': '39475061','dimension10': '','dimension12': '2020-02-05 19:17:00','dimension13': '18','dimension14': 'article','dimension15': '971','dimension16': 'featured','dimension18': swiftLanguage});

			ga('provide', 'adblockTracker', function(tracker, opts) {
			  var ad = document.createElement('ins');
			  ad.className = 'AdSense';
			  ad.style.display = 'block';
			  ad.style.position = 'absolute';
			  ad.style.top = '-1px';
			  ad.style.height = '1px';
			  document.body.appendChild(ad);
				var adBlockEnabled = !ad.clientHeight ? 'yes' : 'no';
			  tracker.set('dimension' + opts.dimensionIndex, adBlockEnabled);
			  document.body.removeChild(ad);
			});
			ga('require', 'adblockTracker', {dimensionIndex: 11});
      var currLocation = String(document.location);
      // strip out email addresses from location url
      var emailRegex = /([a-zA-Z0-9_\.-]+)@([\da-zA-Z\.-]+)\.([a-zA-Z\.]{2,6})/i;
      var cleanPageLocation = currLocation.replace(emailRegex, "");

      ga('set', 'location', cleanPageLocation);
			ga('set', 'anonymizeIp', true);
			ga('newTracker.set', 'location', cleanPageLocation);
			ga('newTracker.set', 'anonymizeIp', true);
				ga('send', 'pageview');
				ga('newTracker.send', 'pageview');</script><script>var chartbeatUser = ''
	        var _sf_async_config = _sf_async_config || {};
	        _sf_async_config.uid = 57640; _sf_async_config.domain = 'swiftcom.com'; _sf_async_config.useCanonical = true; _sf_async_config.useCanonicalDomain = true;
	      	_sf_async_config.sections = 'SierraSun.com,news';
	      	_sf_async_config.authors = 'John Orona';
	        _sf_async_config.title = 'Nevada County Board of Supervisor candidates make their case to voters | SierraSun.com';
	  			var _cbq = window._cbq = (window._cbq || []);
	      	_cbq.push(['_acct', chartbeatUser]);
	        (function(){
	          function loadChartbeat() {
	            window._sf_endpt=(new Date()).getTime();
	            var e = document.createElement('script');
	            e.setAttribute('language', 'javascript');
	            e.setAttribute('type', 'text/javascript');
	            e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
	            document.body.appendChild(e);
	          }
	          var oldonload = window.onload;
	          window.onload = (typeof window.onload != 'function') ?
	              loadChartbeat : function() {
	                  oldonload();
	                  loadChartbeat();
	              };
	        })();</script><script>jQuery( window ).on( 'load', function() {
		$( '.video-carousel').on('slide.bs.carousel', function(evt) {
			var videoIFrame = $( 'iframe[allow]', $( '.carousel-item', this)[evt.from] )[0];
			if( videoIFrame && videoIFrame.contentWindow && videoIFrame.contentWindow.postMessage ) {
				videoIFrame.contentWindow.postMessage("pauseplz", "https://player.swiftcom.com");
			}
		});
	});</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://cdn.sierrasun.com/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script> </body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1581020765 -->